server126

507 经验值

站长是否能推荐一个您使用的v#p#n呀,我发现最近插的比较严格,我的付费的VPN都不太好用了,特别是访问github.io,,,,都无法访问......无语

感谢楼主的分享,非常不错,谢谢!

那要是这样,我就没有必要引入cors包了吧

换句话说吧

laravel 5.1的项目引入使用laravel-cors包,访问api报错

错误信息如下:
TokenMismatchException in VerifyCsrfToken.php line 53:

那我的项目中使用这个包,然后想解决跨域的问题,但是跨域调用失败,错误信息:

TokenMismatchException in VerifyCsrfToken.php line 53:

如何解决这个问题?

因为我项目中不全都是api接口,还有网站其他模块呢

追问一下,如果这样过滤,那项目不引入 laravel-cors 包也可以吧?那想就没有必要引入laravel-cors包,对不对?

版本:laravel 5.1
系统:Mac Pro

laravel项目引入了laravel-cors;链接地址:https://github.com/barryvdh/laravel-cors

所有配置都安装GitHub上的正确配置完毕,项目可以正常运行,但是发现跨域访问api还是无法访问:报错还是VerifyCsrfToken的问题;

后来注释掉Kernel.php文件中的"VerifyCsrfToken"后,api就可以正常访问了

protected $middleware = [
 //  \App\Http\Middleware\VerifyCsrfToken::class,
    ];

我想问一下,能不能在不注释掉上面那行代码,继续可以跨域访问api呀?
因为项目中不全是api服务,还有wen网站呢
其实我只想当api服务的时候可以继续跨域访问,但是web网站继续使用VerifyCsrfToken检查功能

都可以登录成功,我觉得不应该是数据库的问题吧